[Box Backup] free(): invalid pointer

Ben Summers boxbackup@fluffy.co.uk
Wed, 8 Dec 2004 17:48:30 +0000

On 8 Dec 2004, at 17:43, Dennis Heltzel wrote:

> Yesterday, I compiled the latest version without errors and was able to
> setup and test both server and client. Today I found that the client
> daemon had died and when I tried to restart it, I get this:
> Box Backup Client v0.09, (c) Ben Summers 2003, 2004
> free(): invalid pointer 0x80a08d4!
> free(): invalid pointer 0x80a08d4!
> free(): invalid pointer 0x80a08d4!
> free(): invalid pointer 0x80a08d4!
> Segmentation fault
> Rebooting the system didn't help and bbstored seems to be running fine  
> on
> the server. I even re-did the configure/compile and replace the  
> binaries,
> with the same result.
> Both systems are Fedora Core 2 and the following libs were updated
> recently (possibly within the timeframe the it worked, then failed):
> glib2-2.4.8-1.fc2
> glib2-devel-2.4.8-1.fc2
> gtk2-2.4.14-1.fc2
> gtk2-devel-2.4.14-1.fc2
> libpng10-1.0.18-1.fc2
> libpng10-devel-1.0.18-1.fc2
> libpng-1.2.8-1.fc2
> libpng-devel-1.2.8-1.fc2
> Any ideas about how I might be able to get this to work?

How are you with a debugger?

If so, build a debug version


run it, and see where it goes bang. Post a backtrace, and we'll go from  

Or try the tests... do

   ./runtest.pl bbackupd

from the distribution root after ./configure, to run the long test for  
the backup daemon, in debug mode.

I don't think the libraries you mention are used, unless glib2 gets  
linked in somehow by g++. But I'm not an expert on Linux, so have no