[Box Backup] Win32 Port - bbackupctl issue with configuration file

Chris Hane boxbackup@fluffy.co.uk
Mon, 08 Nov 2004 10:29:50 -0600

Content-Type: text/plain; x-avg-checked=avg-ok-3CB42557; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 8bit

Thanks for the reply...I don't know what I was doing wrong...bbackupctl is 
now finding the bbackup.conf file just fine.  However, the second issue of 
the daemon not writing a PID file is causing the error I'm seeing 
now.  When I start the bbackupctl I get 1 error message (in the event log) 
indicating it can not find the command socket.

Error message from command prompt:
C:\Program Files\Box Backup>bbackupctl.exe sync

Using configuration file C:\Program Files\Box Backup\bbackupd.conf
Failed to connect to daemon control socket.
Possible causes:
   * Daemon not running
   * Daemon busy syncing with store server
   * Another bbackupctl process is communicating with the daemon
   * Daemon is waiting to recover from an error
Failed to connect to the command socket

I don't see anything in the event log for the daemon that looks like an 
error.  When I start the bbackupd there a several entries (start, login, 
get file list, ....) that indicate a successful startup.

On my machine it doesn't look like it is creating the PID file or the 
command socket.  I have tried different settings for these in the 
bbackup.conf file.  The current ones are the defaults that shipped with the 
program.  Also, I am running under and administrator account and have full 
access to all directories on the machine.

  CommandSocket = bbackupd/bbackupd.sock

         PidFile = C:\Program Files\Box Backup\bbackupd\bbackupd.pid

Also, the "C:\Program Files\Box Backup\bbackupd" directory does exist.


At 05:30 AM 11/7/2004, Ben Summers wrote:

>On 6 Nov 2004, at 00:17, Chris Hane wrote:
>>I am getting the following error when trying to test the Win32 client 
>>(posted by Nick Knight) version 0.8f.
>>I have:
>>  - installed the server on a Linux box and have Linux clients backing up 
>> to it
>>  - installed the client on Win32
>>  - can query the server with "bbackupquery -c bbackupd.conf"
>>  - can run the daemon "bbackupd -c bbackupd.conf"
>>When I run the client [bbackupctl -c bbackupd.conf] I get the following 
>>C:\Program Files\Box Backup>bbackupctl -c bbackupd.conf synch
>>Using configuration file
>>Exception: Common (1/2)
>>I'm probably doing something very simple wrong.  I just don't see what is 
>>wrong in the config file (or am I specifying the path incorrectly).  I 
>>have installed the win32 client in the default location of ("program
>>files\box backup").  Also, I am running on Windows XP.
>The error means that it cannot open the config file (it appears the Win32 
>client is built without the full error messages which would have suggested 
>Which directory are you running the command from? Type "dir" first, and if 
>bbackup.conf is not listed, then that's your problem. In which case try 
>something like
>bbackupctl -c "c:\Program Files\Box Backup\bbackupd.conf" sync
>>As a note, when I look in the PID directory below there is not a file 
>>named bbackupd.pid.  Could that be the issue?
>Not with bbackupctl. It might suggest that the daemon isn't actually 
>running though. Check your logs.
>boxbackup mailing list