[Box Backup] Release Candidate 3, gcc, g++, readline problems

E.W. Peter Jalajas boxbackup@fluffy.co.uk
Sun, 19 Feb 2006 11:53:55 -0800 (PST)

Thanks, Stefan.

As that faded poster on my mother's wall said, "Nothing takes the place
of persistence...".  I tried the symlink but that didn't work.  I
flailed around for an hour uninstalling and reinstalling gcc4 and
gcc3.4 or some such and getting different errors in config.log, and
then, finally:
  106  sudo apt-get install gcc  manpages-dev automake1.9 libtool flex
bison gcc-doc
  108  ./bootstrap
  109  ./configure
saw the cc1plus error again, googled it, found
which says:  Solved: # apt-get install g++
  111  apt-get install g++
  112  ./bootstrap
  113  ./configure
and the rest, they say, is:
  114  history

I noticed at the end of the ./config out that readline said no.  
Large files:         yes
Berkeley DB:         yes
Readline:            no
Extended attributes: yes

Flailing, I drink exactly one (40 oz) beer, I swear, and got out my
apt-get shotgun:
  118 apt-get install libreadline4-dev
  119  apt-get install libreadline4
  120  apt-get install libreadline5-dev
but it still said no.  Then I shot again: 
  126  apt-get install libedit2 libedit-dev libeditline-dev
and then readline worked (not sure if I needed ALL 3 editline packages
or ANY of the readline packages, and too compile-exhausted to rerun
checking for editline library... -ledit
checking editline/readline.h usability... yes
checking editline/readline.h presence... yes
checking for editline/readline.h... yes
checking whether editline supports history... yes
checking for editline/readline.h... (cached) yes
Large files:         yes
Berkeley DB:         yes
Readline:            yes
Extended attributes: yes

Luckily, no one got hurt.  

Eighteen hours later, I can report that I see the Extended attributes:
yes and all the mail traffic about xattr.  Let me know if you need me
to do anything with that (I have no idea what it all means or where I
would start).

Thanks again, Stefan, for pointing me in the right direction.

Ok, now where was I...


--- Stefan Norlin <stefan.norlin@infoflexconnect.se> wrote:

> >> > checking for C++ compiler default output file name... configure:
> >> error:
> >> > C++ compiler cannot create executables
> >> > See `config.log' for more details.
> You seem to have some kind of problem with your g++
> installation?
> You have these lines in your config.log.
> configure:1585: g++ conftest.cc >&5
> g++: installation problem, cannot exec 'cc1plus': No such file or
> directory
> configure:1588: $? = 1
> If you search google for
> g++: installation problem, cannot exec 'cc1plus': No such file or
> directory
> you find all kinds of problem descriptions and solutions.
> For example there is some symlink solution in this thread:
> http://www.linuxquestions.org/questions/showthread.php?t=124961
> Cheers,
> Stefan
> _______________________________________________
> boxbackup mailing list
> boxbackup@fluffy.co.uk
> http://lists.warhead.org.uk/mailman/listinfo/boxbackup