[Box Backup] Symlink error in bbackupd?

Hans-Joachim Baader boxbackup@fluffy.co.uk
Wed, 7 Nov 2007 20:43:37 +0100

Content-Type: text/plain; charset=iso-8859-15
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Hi Chris,

> >I guess you added the fix in changeset 1923. However I cannot verify=20
> >that it fixes the problem. My trace shows no access to lstat.
> >Were there changes to bbackupd? I only tried the latest bbackupquery.=20
> >Maybe you missed a 'stat' somewhere or I missed to redo the backup.
> No changes to bbackupd, I didn't miss a stat, and the backup doesn't need=
> to be redone. The error is only on restore. The change is one line,=20
> changing stat() to lstat() in lib/common/Utils.cpp.

my fault. I had only tried to resume the restore (-r option). When
I removed the directory and the resume info everything was restored
correctly and I also see the lstat64 in the trace now.

BTW I have written an article about BoxBackup. It's in German and it was
published in March on our site:
I plan to publish an update soon. It's already finished but we will
publish one or two other articles before.

Thank you,
Pro-Linux - Germany's largest volunteer Linux support site
http://www.pro-linux.de/          Public Key ID 0x3DDBDDEA

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.4.6 (GNU/Linux)